Dwr issue in eclipse tomcat 7 server

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Dwr issue in eclipse tomcat 7 server

Thilak Kumar Maskibail
Hi,

Currently we use DWR 3.0.0.RC2-final in our maven spring web project.

We use eclipse Kepler 64-bit IDE and tomcat 7 configured as server in the IDE. We use JDK 1.7 in our project.

When we deploy the WAR file in a standalone tomcat server (not related to eclipse), the web pages load correctly. However, when we deploy the same app in eclipse tomcat (right click on web project -> run as -> run on server) the pages take a lot of time to load.

I see the below warning message in the log files:

CommonsLogger.warn - No configuration found for the specified action: 'noAction' in namespace: '/'. Form action defaulting to ' action' attributes literal value.
CommonsLogger.warn - No configuration found for the specified action: 'noAction1' in namespace: '/'. Form action defaulting to ' action' attributes literal value.

These lines repeat until we get the below warning:

NotFoundHandler.handle - page not found. PathInfo='pt.js' requestUrl='/<project war>/dwr/pt.js'


Could you help us I saving this issue so that we can run web apps on eclipse tomcat server please?

Many thanks,

Thilak




Reply | Threaded
Open this post in threaded view
|

Re: Dwr issue in eclipse tomcat 7 server

Mike Wilson
Administrator
Please don't crosspost. Your post is about using DWR and not
about developing DWR so keep to the users list.

Mike Wilson

Thilak Kumar Maskibail wrote:

> Hi,
>
> Currently we use DWR 3.0.0.RC2-final in our maven spring web project.
>
> We use eclipse Kepler 64-bit IDE and tomcat 7 configured as
> server in the IDE. We use JDK 1.7 in our project.
>
> When we deploy the WAR file in a standalone tomcat server
> (not related to eclipse), the web pages load correctly.
> However, when we deploy the same app in eclipse tomcat (right
> click on web project -> run as -> run on server) the pages
> take a lot of time to load.
>
> I see the below warning message in the log files:
>
> CommonsLogger.warn - No configuration found for the specified
> action: 'noAction' in namespace: '/'. Form action defaulting
> to ' action' attributes literal value.
> CommonsLogger.warn - No configuration found for the specified
> action: 'noAction1' in namespace: '/'. Form action defaulting
> to ' action' attributes literal value.
>
> These lines repeat until we get the below warning:
>
> NotFoundHandler.handle - page not found. PathInfo='pt.js'
> requestUrl='/<project war>/dwr/pt.js'
>
>
> Could you help us I saving this issue so that we can run web
> apps on eclipse tomcat server please?
>
> Many thanks,
>
> Thilak
>
>
>
>