Problems deploying DRW application in weblogic 12.1.3.0.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems deploying DRW application in weblogic 12.1.3.0.0

dragon2014
Hi, I have read several post about dwr and weblogic but i have not
found a solution, please i need help.
My dwr version is dwr-3.0.0-rc3-RELEASE and my weblogic version is
12.1.3.0.0
I have the following configuration in my web.xml
<servlet>
                <display-name>DWR Servlet</display-name>
                <servlet-name>dwr-invoker</servlet-name>
               
<servlet-class>org.directwebremoting.servlet.DwrServlet</servlet-class>
                <init-param>
                        <param-name>debug</param-name>
                        <param-value>false</param-value>
                </init-param>
                <init-param>
                        <param-name>generateDtoClasses</param-name>
                        <param-value>dto</param-value>
                </init-param>
                <init-param>
                       
<param-name>initApplicationScopeCreatorsAtStartup</param-name>
                        <param-value>true</param-value>
                </init-param>
                <init-param>
                        <param-name>config</param-name>
                       
<param-value>/WEB-INF/dwr.xml,/WEB-INF/dwr-custom.xml</param-value>
                </init-param>
                <load-on-startup>1</load-on-startup>
        </servlet>

The tag <load-on-startup>1</load-on-startup> makes possible that DWR
initialize correctly in weblogic but the server.log shows the error

<Error> <HTTP>
<AP03CMPROD> <OmniaServer> <[STANDBY] ExecuteThread: '3' for
queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <>
<ca7a250a-50ac-4c63-b97e-ca33aafb2d15-0000000e>
<1482747833333> <BEA-101388> <The ServletContext was
passed to the ServletContextListener.contextInitialized method
of a ServletContextListener that was neither declared in web.xml
or web-fragment.xml, nor annotated with
javax.servlet.annotation.WebListener.>


I executed a debug in DWR code and the problem fires when execute the
class
org.directwebremoting.server.servlet3.Servlet30ContainerAbstraction
method isNativeEnvironment.
I have spend some days with this problem.
I hope that you can help me.
thanks