Re: ERROR deploying DRW application in weblogic 12.1.3.0.0

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: ERROR deploying DRW application in weblogic 12.1.3.0.0

dragon2014
Hi  Mike i have installed WebLogic 12.2.1.2.0 and i have deployed your
dwrdemo.war. The web application was deployed successfully and the log
does not show the error BEA-101388 anymore. this version works!!
Your web Application works without errors.
I hope this information about deploying DWR in weblogic 12.2.1.2.0 help
you.
Reply | Threaded
Open this post in threaded view
|

Re: ERROR deploying DRW application in weblogic 12.1.3.0.0

Mike Wilson
Administrator
Great, so now we know that my conclusions were correct and we can
continue from there. It is now verified that what you are seeing
is a bug in Weblogic 12.1.3. It is a very basic bug and other
projects that do non-trivial servlet usage like Atmospehere
and Liferay have also seen it.

As this is a bug in Weblogic the appropriate action is to ask
Oracle for a hotfix, unless your customer wants to upgrade to 12.2.
I'm certain Oracle knows about the bug but as they keep their bug
database behind closed doors I can't point to the exact bug ticket.
I can give you a few details about the bug if you want to contact
Oracle on behalf of your customer.

If updating to a working version of Weblogic is not an option I
can suggest workarounds for you, but what to do depends on if you
are using Reverse Ajax in asynchronous Servlet 3.0 mode, or if
Servlet 2.4 mode is sufficient (easier workaround just to get rid
of the message).

Best regards
Mike

santiago.parraga wrote:
> Hi  Mike i have installed WebLogic 12.2.1.2.0 and i have deployed your
> dwrdemo.war. The web application was deployed successfully and the log
> does not show the error BEA-101388 anymore. this version works!!
> Your web Application works without errors.
> I hope this information about deploying DWR in weblogic
> 12.2.1.2.0 help
> you.