Spring 4.0.0.M3 compatiblity issues with dwr 3.0.M1

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Spring 4.0.0.M3 compatiblity issues with dwr 3.0.M1

Kornel
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: Spring 4.0.0.M3 compatiblity issues with dwr 3.0.M1

david@butterdev.com
Hi Kornel.   Thanks for letting us know.  I have created an issue for
this:
http://directwebremoting.org/jira/browse/DWR-614

I should be able to get it resolved quickly but you will have to use a
development build of 3.x.


On 2013-10-22 06:59, Kornel wrote:

> Hello.
>  org.directwebremoting.spring.DwrNamespaceHandler uses the deprecated
> in Spring 3 org.springframework.util.ClassUtils.forName method, which
> does not exist in Spring 4. Spring suggests to use the method with the
> explicitly specified class loader argument, which is the only one left
> in Spring 4. 
>
>     public static Class<?> forName(String name, ClassLoader
> classLoader) throws ClassNotFoundException, LinkageError;
>
> Would it be possible to change the calls to forName(String) to
> forName(String, ClassLoader)? I wanted to switch to Spring 4 and now
> with this issue I need to build dwr myself.
>
> Regards,
>  Kornel